summary refs log tree commit diff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-04-12 20:09:58 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-04-15 12:10:19 +0200
commit8e84eb6847abada85001f77547be096feb1215cc (patch)
tree94c6b5161e59aacfffbb5800b47330ef93fa8cae /gnu/packages/python-crypto.scm
parentfc12113704255616522cb56fc37b4a18fccd84eb (diff)
downloadguix-8e84eb6847abada85001f77547be096feb1215cc.tar.gz
gnu: python-paramiko: Update to 2.4.1 [fixes CVE-2018-7750].
* gnu/packages/python-crypto.scm (python-paramiko): Update to 2.4.1.
[arguments]: Set #:tests? #f.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 5bfaab1718..ace0891a7d 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -122,21 +122,18 @@ John the Ripper).")
 (define-public python-paramiko
   (package
     (name "python-paramiko")
-    (version "2.1.5")
+    (version "2.4.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "paramiko" version))
        (sha256
         (base32
-         "1pf0zxzhgyy4avby3ajg5hp18b0d8iirbkdfw53z0h6w611bp0wk"))))
+         "1wx4s95i2cdh8hhi1c3jb8lzk71jifa3z9wjfsx905y7lrsngqrk"))))
     (build-system python-build-system)
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda _
-             (zero? (system* "python" "test.py")))))))
+     `(;; FIXME: Tests require many unpackaged libraries, see dev-requirements.txt.
+       #:tests? #f))
     (propagated-inputs
      `(("python-pyasn1" ,python-pyasn1)
        ("python-cryptography" ,python-cryptography)))