summary refs log tree commit diff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-05-17 01:00:50 -0400
committerMark H Weaver <mhw@netris.org>2018-05-17 01:00:50 -0400
commit539bf8f2c071b53834829259bb3fabf0390c5dc6 (patch)
tree16672732afbf4c3f933e67ac677aa1877f6a7657 /gnu/packages/python-crypto.scm
parent903874328ed5e5ab766e36cee1b1a0989e8b24a9 (diff)
parent2cf8531f360ef390d3ec670cc150b106bab5eff1 (diff)
downloadguix-539bf8f2c071b53834829259bb3fabf0390c5dc6.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm124
1 files changed, 124 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 48e84521c5..b7cd51e868 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -16,6 +16,7 @@
 ;;; Copyright © 2016, 2017 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
 ;;; Copyright © 2018 Tomáš Čech <sleep_walker@gnu.org>
+;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -44,11 +45,32 @@
   #:use-module (gnu packages multiprecision)
   #:use-module (gnu packages protobuf)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-web)
   #:use-module (gnu packages time)
   #:use-module (gnu packages tls)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (srfi srfi-1))
 
+(define-public python-base58
+  (package
+    (name "python-base58")
+    (version "1.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "base58" version))
+       (sha256
+        (base32
+         "0lgnk7ycdxwhk2bkygl30nsks56bvrdj79ix76iv965pz808pzn5"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-pyhamcrest" ,python-pyhamcrest)))
+    (home-page "https://github.com/keis/base58")
+    (synopsis "Base58 and Base58Check implementation")
+    (description "Base58 and Base58Check implementation compatible
+with what is used by the Bitcoin network.")
+    (license license:expat)))
+
 (define-public python-bcrypt
   (package
     (name "python-bcrypt")
@@ -821,3 +843,105 @@ through the Engine interface.")
 
 (define-public python2-m2crypto
   (package-with-python2 python-m2crypto))
+
+(define-public python-pylibscrypt
+  (package
+    (name "python-pylibscrypt")
+    (version "1.7.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pylibscrypt" version))
+       (sha256
+        (base32
+         "1b3rgzl6dbzs08vhv41b6y4n5189wv7lr27acxn104hs45745abs"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f))                    ;FIXME: unable to find libraries
+    (inputs
+     `(("openssl" ,openssl)))
+    (home-page "https://github.com/jvarho/pylibscrypt")
+    (synopsis "Scrypt for Python")
+    (description "There are a lot of different scrypt modules for Python, but
+none of them have everything that I'd like, so here's one more.  It uses
+hashlib.scrypt on Python 3.6 and OpenSSL 1.1.")
+    (license license:isc)))
+
+(define-public python-libnacl
+  (package
+    (name "python-libnacl")
+    (version "1.6.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "libnacl" version))
+       (sha256
+        (base32
+         "0nv7n8nfswkhl614x5mllrkvaslraa0053q11iylb337cy43vb4v"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'locate-libsodium
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "libnacl/__init__.py"
+               (("(return ctypes.cdll.LoadLibrary\\(')libsodium.so('\\))"
+                 _ pre post)
+                (let ((libsodium (string-append (assoc-ref inputs "libsodium")
+                                                "/lib/libsodium.so")))
+                  (string-append pre libsodium post)))))))))
+    (native-inputs
+     `(("python-pyhamcrest" ,python-pyhamcrest)))
+    (inputs
+     `(("libsodium" ,libsodium)))
+    (home-page "https://libnacl.readthedocs.org/")
+    (synopsis "Python bindings for libsodium based on ctypes")
+    (description "@code{libnacl} is used to gain direct access to the
+functions exposed by @code{NaCl} library via @code{libsodium}.  It has
+been constructed to maintain extensive documentation on how to use
+@code{NaCl} as well as being completely portable.")
+    (license license:asl2.0)))
+
+(define-public python-duniterpy
+  (package
+    (name "python-duniterpy")
+    (version "0.43.2")
+    (source
+     (origin
+       (method git-fetch)
+       ;; Pypi's default URI is missing "requirements.txt" file.
+       (uri (git-reference
+             (url "https://github.com/duniter/duniter-python-api.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1ch4f150k1p1l876pp08p5rxqhpv5xfbxdw6njcmr06hspv8v8x4"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; Among 108 tests, a single one is failing: FAIL:
+         ;; test_from_pubkey.  Remove it.
+         (add-after 'unpack 'remove-failing-test
+           (lambda _
+             (delete-file "tests/documents/test_crc_pubkey.py")
+             #t)))))
+    (propagated-inputs
+     `(("python-aiohttp" ,python-aiohttp)
+       ("python-base58" ,python-base58)
+       ("python-jsonschema" ,python-jsonschema)
+       ("python-libnacl" ,python-libnacl)
+       ("python-pylibscrypt" ,python-pylibscrypt)
+       ("python-pypeg2" ,python-pypeg2)))
+    (home-page "https://github.com/duniter/duniter-python-api")
+    (synopsis "Python implementation of Duniter API")
+    (description "@code{duniterpy} is an implementation of
+@uref{https://github.com/duniter/duniter/, duniter} API. Its
+main features are:
+@itemize
+@item Supports Duniter's Basic Merkle API and protocol
+@item Asynchronous
+@item Duniter signing key
+@end itemize")
+    (license license:gpl3+)))