summary refs log tree commit diff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-12-24 01:51:20 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-12-25 23:42:48 +0100
commit579b43625236d1d1cb0fc4872ce4fdd33cda1c4d (patch)
tree36b2996afac5e9571ac1d35e3925f943af424e61 /gnu/packages/python-crypto.scm
parent467cfaa3fcf4f1d45c07ed0f3ba5d85a079f0fd3 (diff)
downloadguix-579b43625236d1d1cb0fc4872ce4fdd33cda1c4d.tar.gz
gnu: Add python-ed25519.
* gnu/packages/python-crypto.scm (python-ed25519, python2-ed25519): New
variables.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 77409d86d2..9a7b0c7d78 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -396,6 +396,26 @@ library.")
 (define-public python2-pyopenssl
   (package-with-python2 python-pyopenssl))
 
+(define-public python-ed25519
+  (package
+    (name "python-ed25519")
+    (version "1.4")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "ed25519" version))
+        (sha256
+          (base32
+            "0ahx1nkxa0xis3cw0h5c4fpgv8mq4znkq7kajly33lc3317bk499"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/warner/python-ed25519")
+    (synopsis "Ed25519 public-key signatures")
+    (description "Ed25519 public-key signatures")
+    (license license:expat)))
+
+(define-public python2-ed25519
+  (package-with-python2 python-ed25519))
+
 (define-public python-axolotl-curve25519
   (package
     (name "python-axolotl-curve25519")