summary refs log tree commit diff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 23:40:51 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:35 -0400
commit30413f1180de483b99e757d5b5c21ed775b1fc29 (patch)
tree7b4faf6c37cd12843d2a95dc4413369c696024fc /gnu/packages/python-science.scm
parent5ab0cbd0f1e0fa7cca3052a51f032460fb3bb17c (diff)
downloadguix-30413f1180de483b99e757d5b5c21ed775b1fc29.tar.gz
gnu: Remove python2-scipy.
* gnu/packages/python-science.scm (python2-scipy): Delete variable.
(python-scipy)[properties]: Delete field.
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm24
1 files changed, 0 insertions, 24 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index ccff510ef6..855fe9a72c 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -154,32 +154,8 @@ atlas_libs = openblas~%"  #$(this-package-input "openblas"))))))
     (description "The SciPy library is one of the core packages that make up
 the SciPy stack.  It provides many user-friendly and efficient numerical
 routines such as routines for numerical integration and optimization.")
-    (properties `((python2-variant . ,(delay python2-scipy))))
     (license license:bsd-3)))
 
-;; Version 1.2.2 is the last version to support Python 2
-(define-public python2-scipy
-  (package
-    (inherit (package-with-python2
-              (strip-python2-variant python-scipy)))
-    (version "1.2.2")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "scipy" version))
-       (sha256
-        (base32
-         "1cgvgin8fvckv96hjh3ikmwkra5rif51bdb75ifzf7xbil5iwcx4"))))
-    (native-inputs
-     (list python2-cython
-           python2-pytest
-           python2-sphinx
-           python2-numpydoc
-           gfortran-7
-           gcc-7
-           perl
-           which))))
-
 (define-public python-scikit-fuzzy
   (package
     (name "python-scikit-fuzzy")