summary refs log tree commit diff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-08 23:45:21 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-09 11:17:45 +0100
commit3ebcd637a589cbea1868992bd5c6f2b8477181fc (patch)
tree91cfefb71dc8f3623df74bd43b1870722303b313 /gnu/packages/python-science.scm
parent3cd37c94bd92091d72c7437e1b250417ce297a6f (diff)
downloadguix-3ebcd637a589cbea1868992bd5c6f2b8477181fc.tar.gz
gnu: python2-scipy: Override native inputs.
* gnu/packages/python-science.scm (python2-scipy)[native-inputs]: Override;
replace gfortran with gfortran-7; add gcc-7.
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 0677843216..eb1f8312cd 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -186,7 +186,16 @@ routines such as routines for numerical integration and optimization.")
        (uri (pypi-uri "scipy" version))
        (sha256
         (base32
-         "1cgvgin8fvckv96hjh3ikmwkra5rif51bdb75ifzf7xbil5iwcx4"))))))
+         "1cgvgin8fvckv96hjh3ikmwkra5rif51bdb75ifzf7xbil5iwcx4"))))
+    (native-inputs
+     `(("python-cython" ,python2-cython)
+       ("python-pytest" ,python2-pytest)
+       ("python-sphinx" ,python2-sphinx)
+       ("python-numpydoc" ,python2-numpydoc)
+       ("gfortran" ,gfortran-7)
+       ("gcc" ,gcc-7)
+       ("perl" ,perl)
+       ("which" ,which)))))
 
 (define-public python2-weave
   (package