summary refs log tree commit diff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 17:38:22 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:52:37 -0400
commitb827d0f7b3b7ec00406f8aa0ca4abc9e36a8da83 (patch)
tree66e00e0c095d5107f40d6fd687fa8df6b4878d21 /gnu/packages/python-science.scm
parent385fa1a3ed155591b07978c577ed55547319ba37 (diff)
downloadguix-b827d0f7b3b7ec00406f8aa0ca4abc9e36a8da83.tar.gz
gnu: Remove python2-weave.
* gnu/packages/python-science.scm (python2-weave): Delete variable.
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm33
1 files changed, 0 insertions, 33 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 0b3547f552..ccff510ef6 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -180,39 +180,6 @@ routines such as routines for numerical integration and optimization.")
            perl
            which))))
 
-(define-public python2-weave
-  (package
-    (name "python2-weave")
-    (version "0.16.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "weave" version))
-       (sha256
-        (base32 "0jnm3584mfichgwgrd1gk5i42ll9c08nkw9716n947n4338f6ghs"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:python ,python-2
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda _
-             (invoke "nosetests" "-v"
-                     "--exclude"
-                     "test_(user|incorrect_ownership|char_fail|obj_fail)"))))))
-    (propagated-inputs
-     (list python2-numpy))
-    (native-inputs
-     (list python2-nose))
-    (home-page "https://www.scipy.org/")
-    (synopsis "Tools for including C/C++ code within Python code")
-    (description "Weave is the stand-alone version of the obsolete Scipy
-submodule @code{scipy.weave}.  It is Python 2.x only, and is provided for
-users that need new versions of Scipy but have existing code that still
-depends on @code{scipy.weave}.  For new code, users are recommended to use
-Cython.")
-    (license license:bsd-3)))
-
 (define-public python-scikit-fuzzy
   (package
     (name "python-scikit-fuzzy")