summary refs log tree commit diff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 14:24:37 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 14:27:28 -0400
commit3c6e220d8100281074c414a43c1efe9a01b53771 (patch)
treedc5d47fbbac3842d0da893adcd398dea10c1e681 /gnu/packages/python-science.scm
parent08473753a0ebafef22c0894d846e3b42fd6be2a2 (diff)
parent62048ff9fcfbe3fc790a7207fc5f6f3e0476a02a (diff)
downloadguix-3c6e220d8100281074c414a43c1efe9a01b53771.tar.gz
Merge branch 'master' into staging.
With resolved conflicts in:
	gnu/local.mk
	gnu/packages/crates-io.scm
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 80acb606b2..8ebf3d27b1 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -45,12 +45,14 @@
   #:use-module (gnu packages build-tools)
   #:use-module (gnu packages check)
   #:use-module (gnu packages cpp)
+  #:use-module (gnu packages crypto)
   #:use-module (gnu packages databases)
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages image-processing)
   #:use-module (gnu packages machine-learning)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages mpi)
+  #:use-module (gnu packages pcre)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
@@ -1492,6 +1494,62 @@ well as potentially any library which conforms to a standard API. See the
 documentation for more information.")
     (license license:expat)))
 
+(define-public python-vaex-core
+  (package
+    (name "python-vaex-core")
+    (version "4.13.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "vaex-core" version))
+       (sha256
+        (base32 "0ni862x5njhfsldjy49xmasd34plrs7yrmkyss6z1b6sgkbw9fsb"))
+       (modules '((guix build utils)))
+       (snippet
+        ;; Remove bundled libraries
+        '(for-each delete-file-recursively
+                   (list "vendor/boost"
+                         "vendor/pcre"
+                         "vendor/pybind11")))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #false ;require vaex.server and others, which require vaex-core.
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "pytest" "-vv" )))))))
+    (inputs
+     (list boost pcre pybind11-2.3))
+    (propagated-inputs
+     (list python-aplus
+           python-blake3
+           python-cloudpickle
+           python-dask
+           python-filelock
+           python-frozendict
+           python-future
+           python-nest-asyncio
+           python-numpy
+           python-pandas
+           python-progressbar2
+           python-pyarrow
+           python-pydantic
+           python-pyyaml
+           python-requests
+           python-rich
+           python-six
+           python-tabulate))
+    (native-inputs
+     (list python-pytest python-cython))
+    (home-page "https://www.github.com/maartenbreddels/vaex")
+    (synopsis "Core of Vaex library for exploring tabular datasets")
+    (description "Vaex is a high performance Python library for lazy
+Out-of-Core DataFrames (similar to Pandas), to visualize and explore big
+tabular datasets.  This package provides the core modules of Vaex.")
+    (license license:expat)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar