summary refs log tree commit diff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-03-09 12:51:14 -0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-03-13 13:56:07 +0100
commit0455c19fa56396a460d6f707a39b6da6502b90e8 (patch)
treea152503bf60bfb4565f6f56855086c65b2761ae7 /gnu/packages/python-science.scm
parent36062f16b6bce9e5178ba4614d1c8e763a96eb64 (diff)
downloadguix-0455c19fa56396a460d6f707a39b6da6502b90e8.tar.gz
gnu: python-scikit-image: Enable tests.
* gnu/packages/python-science.scm (python-scikit-image)[arguments]: Add phases
related to tests.
[native-inputs]: Add python-codecov, python-flake8, python-pytest,
python-pytest-cov, python-pytest-localserver, python-wheel.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm30
1 files changed, 27 insertions, 3 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 409745819b..79ee7c8bb2 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -36,6 +36,8 @@
   #:use-module (gnu packages maths)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-build)
+  #:use-module (gnu packages python-check)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages sphinx)
@@ -249,9 +251,25 @@ logic, also known as grey logic.")
         (base32 "0wgisa03smhrphcjnhq7waa5vyyd32b67hblapjbqrqqj751idpv"))))
     (build-system python-build-system)
     (arguments
-     ;; TODO: Some tests require running X11 server. Disable them?
-     '(#:tests? #f))
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'change-home-dir
+           (lambda _
+             ;; Change from /homeless-shelter to /tmp for write permission.
+             (setenv "HOME" "/tmp")
+             #t))
+         (replace 'build
+           (lambda _
+             (invoke "make")))
+         (replace 'check
+           (lambda _
+             ;; The following tests require online data.
+             (invoke "python" "-m" "pytest" "skimage" "--doctest-modules" "-k"
+                     (string-append "not test_ndim"
+                                    " and not test_skin")))))))
     ;; See requirements/ for the list of build and run time requirements.
+    ;; NOTE: scikit-image has an optional dependency on python-pooch, however
+    ;; propagating it would enable many more tests that require online data.
     (propagated-inputs
      `(("python-cloudpickle" ,python-cloudpickle)
        ("python-dask" ,python-dask)
@@ -264,7 +282,13 @@ logic, also known as grey logic.")
        ("python-scipy" ,python-scipy)
        ("python-tifffile" ,python-tifffile)))
     (native-inputs
-     `(("python-cython" ,python-cython)))
+     `(("python-codecov" ,python-codecov)
+       ("python-cython" ,python-cython)
+       ("python-flake8" ,python-flake8)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-pytest-localserver" ,python-pytest-localserver)
+       ("python-wheel" ,python-wheel)))
     (home-page "https://scikit-image.org/")
     (synopsis "Image processing in Python")
     (description