summary refs log tree commit diff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-31 09:30:51 +0200
committerRoel Janssen <roel@gnu.org>2021-05-31 09:30:51 +0200
commit47f31c0afec855e3158beb7467f9f20dcae02031 (patch)
tree8a1c6ec58644421f439aabe1acbe3f81155fa31d /gnu/packages/python-science.scm
parentad7c7b5bf62440ee05ff4da908484721d75ca545 (diff)
downloadguix-47f31c0afec855e3158beb7467f9f20dcae02031.tar.gz
gnu: Add python-pyflow.
* gnu/packages/python-science.scm (python-pyflow): New variable.
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 79ee7c8bb2..fdfd03d424 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -11,6 +11,7 @@
 ;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2021 Roel Janssen <roel@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -439,6 +440,27 @@ doing practical, real world data analysis in Python.")
                        "if 'NULL byte' in msg or 'line contains NUL' in msg:"))
                     #t)))))))
 
+(define-public python-pyflow
+  (package
+    (name "python-pyflow")
+    (version "1.1.20")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/Illumina/pyflow/releases/download/v"
+                    version "/pyflow-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1bvfvviw58cndyn862qnv9nj3d9cd3a0dm4vc4sd9vwq8a6z1riv"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f)) ; There is no test suite.
+    (home-page "https://illumina.github.io/pyflow/")
+    (synopsis "Tool to manage tasks in a task dependency graph")
+    (description "This package is a Python module to manage tasks in the
+context of a task dependency graph.  It has some similarities to make.")
+    (license license:bsd-2)))
+
 (define-public python-bottleneck
   (package
     (name "python-bottleneck")