summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2024-07-13 09:46:29 -0500
committerjgart <jgart@dismail.de>2024-07-13 09:46:29 -0500
commit3e7ce72d80878d5b3eb161c37ca97fd6ded33b2f (patch)
treed16c15c0f527d1d1e2c1ca921d5b2d1150d14e69 /gnu/packages/python-web.scm
parentd7fbdd2b162f13f8d039944406b53986d1815b69 (diff)
downloadguix-3e7ce72d80878d5b3eb161c37ca97fd6ded33b2f.tar.gz
Revert "gnu: python-requests-toolbelt: Update to 1.0.0."
This breaks poetry so reverting.

This reverts commit ddb22a10e04c966eaa6ecbc50c3fc75dc3a143c3.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm17
1 files changed, 6 insertions, 11 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 62e92fc9a7..177d1015f0 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -49,7 +49,7 @@
 ;;; Copyright © 2021 Alice Brenon <alice.brenon@ens-lyon.fr>
 ;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
-;;; Copyright © 2022–2024 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2022, 2023 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
 ;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
 ;;; Copyright © 2022 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
@@ -3759,13 +3759,13 @@ portions of your testing code.")
 (define-public python-requests-toolbelt
   (package
     (name "python-requests-toolbelt")
-    (version "1.0.0")
+    (version "0.9.1")
     (source (origin
              (method url-fetch)
              (uri (pypi-uri "requests-toolbelt" version))
              (sha256
               (base32
-               "1ijvip427ki177ycrblcn1mfgsq7ixzpvqqfvidjn0a7s2is10bn"))))
+               "1h3gm88dcjbd7gm229a7x5qkkhnsqsjz0m0l2xyavm2ab3a8k04n"))))
     (build-system python-build-system)
     (arguments
      '(#:phases (modify-phases %standard-phases
@@ -3775,14 +3775,9 @@ portions of your testing code.")
                       (delete-file "tests/test_x509_adapter.py")
                       ;; Fails due to networking (socket.gaierror: [Errno -2]
                       ;; Name or service not known).
-                      (delete-file "tests/test_multipart_encoder.py")
-                      ;; Those tests are not compatible with urllib3 2.0,
-                      ;; according to
-                      ;; https://github.com/requests/toolbelt/pull/356
-                      (delete-file "tests/test_sessions.py")
-                      )))))
-    (native-inputs
-     (list python-betamax python-pyopenssl python-pytest python-trustme))
+                      (delete-file "tests/test_multipart_encoder.py"))))))
+    (native-inputs
+     (list python-betamax python-mock python-pytest))
     (propagated-inputs
      (list python-requests))
     (synopsis "Extensions to python-requests")