summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-27 15:58:32 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-27 15:58:32 +0300
commitafbd988dde65cfe3949286a08be8fa06bc565468 (patch)
treebc89159dcc3d16217e300e2546ab8649bc16a428 /gnu/packages/python-web.scm
parent138c122fef42e49e83b957a1cdf3a7590768aa2a (diff)
downloadguix-afbd988dde65cfe3949286a08be8fa06bc565468.tar.gz
gnu: python-aiohttp: Fix test suite.
* gnu/packages/python-web.scm (python-aiohttp)[arguments]: Adjust custom
'check phase to not load uninstalled code.
[native-inputs]: Replace python-pytest with python-pytest-6.1.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7787003f03..11db797c8a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -202,7 +202,7 @@ API rules.")
                          ;; Disable loading the aiohttp coverage plugin
                          ;; to avoid a circular dependency (code coverage
                          ;; is not very interesting to us anyway).
-                         "-o" "addopts=''")
+                         "-o" "addopts=''" "--ignore=aiohttp")
                  (format #t "test suite not run~%")))))))
     (propagated-inputs
      `(("python-aiodns" ,python-aiodns)
@@ -214,7 +214,7 @@ API rules.")
        ("python-typing-extensions" ,python-typing-extensions)
        ("python-yarl" ,python-yarl)))
     (native-inputs
-     `(("python-pytest" ,python-pytest)
+     `(("python-pytest" ,python-pytest-6.1)
        ("python-pytest-mock" ,python-pytest-mock)
        ("python-re-assert" ,python-re-assert)
        ("gunicorn" ,gunicorn-bootstrap)