summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-10-27 20:31:38 +0200
committerMarius Bakke <marius@gnu.org>2022-10-27 21:30:03 +0200
commite944734ef9afa1ac9b46579934482b7d909ed24e (patch)
tree3264c818aa7f37fb5ca3b9cd1b12687f464ffc6f /gnu/packages/python-web.scm
parent6ef998d54e57c8969bc3db7888fb7d4939a6fa83 (diff)
downloadguix-e944734ef9afa1ac9b46579934482b7d909ed24e.tar.gz
build-system/pyproject: Always run tests verbosely for supported backends.
* guix/build-system/pyproject.scm (pyproject-build): Default to '() instead of
 #false for TEST-FLAGS.
* guix/build/pyproject-build-system.scm (check): Unconditionally enable
verbose test flags.
* doc/guix.texi (Build Systems): Document this change.
* gnu/packages/fontutils.scm (python-glyphslib)[arguments]: Remove verbosity
from #:test-flags.
* gnu/packages/pdf.scm (python-pydyf, weasyprint)[arguments]: Likewise.
* gnu/packages/python-web.scm (python-openapi-spec-validator)[arguments]: Likewise.
* gnu/packages/python-xyz.scm (python-path, python-tempora)[arguments]: Likewise.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index cbc515fc64..59d677ca35 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1648,7 +1648,7 @@ JSON Schema Specification Draft 2020-12.
      (list
       ;; The example tests attempt to fetch resources from the Internet
       ;; (see: https://github.com/p1c2u/openapi-spec-validator/issues/151).
-      #:test-flags #~'("-vv" "-k" "not Example and not Exampe")
+      #:test-flags #~'("-k" "not Example and not Exampe")
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'remove-coverage-pytest-options