summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-11-05 01:58:34 +0000
committerLudovic Courtès <ludo@gnu.org>2021-12-12 00:27:55 +0100
commit365260f4cd2d284d57df739ed41dc8e023059f00 (patch)
tree8edba851c1be71ef36157f897a19d6ee92124d3e /gnu/packages/python-web.scm
parent9660c2f158f296dc162fd08d08c770095a102b2a (diff)
downloadguix-365260f4cd2d284d57df739ed41dc8e023059f00.tar.gz
gnu: Update awscli, python-boto3 and python-botocore.
awscli, botocore and boto3 work together and typically require matching
versions.

* gnu/packages/python-xyz.scm (python-botocore): Update to 1.22.11.
(python-boto3): Update to 1.19.11.
[native-inputs]: Add python-pytest.
* gnu/packages/python-web.scm (awscli): Update to 1.21.11.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 9e7d4113ab..964a045049 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2876,14 +2876,14 @@ supports url redirection and retries, and also gzip and deflate decoding.")
   (package
     ;; Note: updating awscli typically requires updating botocore as well.
     (name "awscli")
-    (version "1.18.203")
+    (version "1.21.11")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri name version))
        (sha256
         (base32
-         "128zg24961j8nmnq2dxqg6a7zwh3qgv87cmvclsdqwwih9nigxv9"))))
+         "0fkivwbx4nind5b7l4jhqm5bb9drgqsclcslrg4aggf9rcs4g4s0"))))
     (build-system python-build-system)
     (arguments
      ;; FIXME: The 'pypi' release does not contain tests.