summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-01-07 13:49:01 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:53:44 -0500
commit9dd5fa2ea6ed45d89148b601598012147bac3dfa (patch)
treeafe303de7b72315646f8c98bd546480763cd4b3c /gnu/packages/python-web.scm
parent774277ac791c9038367ba07efb3f47e4c9ea1fa5 (diff)
downloadguix-9dd5fa2ea6ed45d89148b601598012147bac3dfa.tar.gz
gnu: python-websockets: Fix Python package name.
* gnu/packages/python-web.scm (python-websockets) [arguments]: Add new
phase to fix package name.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 2bb999ec8b..7ba073d26d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5087,7 +5087,15 @@ Plus all the standard features of requests:
          (base32
           "03s3ml6sbki24aajllf8aily0xzrn929zxi84p50zkkbikdd4raw"))))
     (build-system python-build-system)
-    (arguments '(#:tests? #f))  ; Tests not included in release tarball.
+    (arguments
+     '(#:tests? #f  ; Tests not included in release tarball.
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-websockets-package-name-requirement
+           (lambda* (#:key inputs #:allow-other-keys)
+             ;; Python package names use dot as separator.
+             (substitute* "setup.py"
+               (("websockets/extensions") "websockets.extensions")))))))
     (home-page "https://github.com/aaugustin/websockets")
     (synopsis
      "Python implementation of the WebSocket Protocol (RFC 6455 & 7692)")