summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-17 09:09:44 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-19 20:12:16 -0400
commitd0228051b659c02d695b5c351fdae73963a29704 (patch)
tree7bfc254924fe5ea3c9ea41f876ccd165f8861713 /gnu/packages/python-web.scm
parent3c232c1361b5d5f8704c7418953085ff87c705cc (diff)
downloadguix-d0228051b659c02d695b5c351fdae73963a29704.tar.gz
gnu: python-pycares: Update to 4.3.0.
* gnu/packages/python-web.scm (python-pycares): Update to 4.3.0.
[propagated-inputs]: New field.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 91a045c563..31700a860b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4812,17 +4812,17 @@ supports features like HTTP keep-alive, reget, throttling and more.")
 (define-public python-pycares
   (package
     (name "python-pycares")
-    (version "2.3.0")
+    (version "4.3.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pycares" version))
        (sha256
         (base32
-         "0h4fxw5drrhfyslzmfpljk0qnnpbhhb20hnnndzahhbwylyw1x1n"))))
+         "0i8d0433wmm7wi8i2l2hjiyhmy35b9s888qrk6fqx5xcdmpnjhn5"))))
     (build-system python-build-system)
-    (arguments
-     `(#:tests? #f))                    ;tests require internet access
+    (arguments `(#:tests? #f))          ;tests require internet access
+    (propagated-inputs (list python-cffi))
     (home-page "https://github.com/saghul/pycares")
     (synopsis "Python interface for @code{c-ares}")
     (description "@code{pycares} is a Python module which provides an