summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-16 14:15:28 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-16 15:45:37 +0100
commit2585304c6ea7293b71f8db4dd00cd11cb3e07cb5 (patch)
tree5e9cd1489c507df62759eef2f3c2b5ec85e9115b /gnu/packages/python-web.scm
parenta1e9c929fa7e0b8b79f86c32830dad8ca3263b85 (diff)
downloadguix-2585304c6ea7293b71f8db4dd00cd11cb3e07cb5.tar.gz
gnu: python-zope-configuration: Update to 4.3.1.
* gnu/packages/python-web.scm (python-zope-configuration): Update to 4.3.1.
[native-inputs]: Add PYTHON-ZOPE-TESTING and PYTHON-ZOPE-TESTRUNNER.
[propagated-inputs]: Add PYTHON-ZOPE-INTERFACE.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 82185cd81f..b1e60bc2a1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1148,18 +1148,22 @@ defining data schemas.")
 (define-public python-zope-configuration
   (package
     (name "python-zope-configuration")
-    (version "4.0.3")
+    (version "4.3.1")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "zope.configuration" version))
               (sha256
                (base32
-                "1x9dfqypgympnlm25p9m43xh4qv3p7d75vksv9pzqibrb4cggw5n"))))
+                "1qb88764fd7nkkmqv7fl9bxd1jirynkg5vbqkpqdiffnkxzp85kf"))))
     (build-system python-build-system)
     (arguments
      '(#:tests? #f)) ; FIXME: Tests can't find zope.interface.
+    (native-inputs
+     `(("python-zope-testing" ,python-zope-testing)
+       ("python-zope-testrunner" ,python-zope-testrunner)))
     (propagated-inputs
      `(("python-zope-i18nmessageid" ,python-zope-i18nmessageid)
+       ("python-zope-interface" ,python-zope-interface)
        ("python-zope-schema" ,python-zope-schema)))
     (home-page "https://pypi.org/project/zope.configuration/")
     (synopsis "Zope Configuration Markup Language")