summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-20 17:19:05 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-20 17:19:05 +0300
commit6ae5d5da650fcf7814c5365ba138701d47a77dcc (patch)
tree9149c936c565834eb8622c0b18242a811406569d /gnu/packages/python-web.scm
parent2f938b634e0265fc6d3348cdcba9c788303c0136 (diff)
downloadguix-6ae5d5da650fcf7814c5365ba138701d47a77dcc.tar.gz
gnu: python-zope-exceptions: Enable tests.
* gnu/packages/python-web.scm (python-zope-exceptions)[arguments]: Use
custom 'check phase.
[native-inputs]: Add python-zope-testrunner-bootstrap.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index a9f362e0bc..ed37e47448 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1122,7 +1122,13 @@ conforming to a given API or contract.")
          "1nkgfwawswmyc6i0b8g3ymvja4mb507m8yhid8s4rbxq3dmqhwhd"))))
     (build-system python-build-system)
     (arguments
-     '(#:tests? #f))                ; circular dependency with zope.testrunner
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (invoke "zope-testrunner" "--test-path=src"))))))
+    (native-inputs
+     `(("python-zope-testrunner" ,python-zope-testrunner-bootstrap)))
     (propagated-inputs
      `(("python-zope-interface" ,python-zope-interface)))
     (home-page "https://pypi.org/project/zope.exceptions/")