summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-07-15 20:29:26 +0200
committerMarius Bakke <marius@gnu.org>2020-07-15 20:29:26 +0200
commit15076369062852c266bc697fc54b2ba157aceed0 (patch)
tree994a79904744f032ab30b93361bbbcea4d525f50 /gnu/packages/python-web.scm
parentdec0217f6e21a2f48328aaff5448dcf2f4fea7d9 (diff)
downloadguix-15076369062852c266bc697fc54b2ba157aceed0.tar.gz
gnu: python-tinycss2: Fix test failure.
Fixes <https://bugs.gnu.org/42372>.
Reported by Michael Rohleder <mike@rohleder.de>.

* gnu/packages/patches/python-tinycss2-flake8-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/python-web.scm (python-tinycss2)[source](patches): New field.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index a7e5e7081f..1d7cfd852d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3411,6 +3411,7 @@ library to create slugs from unicode strings while keeping it DRY.")
      (origin
        (method url-fetch)
        (uri (pypi-uri "tinycss2" version))
+       (patches (search-patches "python-tinycss2-flake8-compat.patch"))
        (sha256
         (base32 "1kw84y09lggji4krkc58jyhsfj31w8npwhznr7lf19d0zbix09v4"))))
     (build-system python-build-system)