summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-27 08:43:29 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-27 08:43:29 +0200
commit0dc7f773fd08f21a94779484ed947dedc1c15fdd (patch)
treea235981205aff0858caab7417ae1157a32ebeda1 /gnu/packages/python-web.scm
parentd8fe2e47352b53362bb32ffb480363a540533b5b (diff)
downloadguix-0dc7f773fd08f21a94779484ed947dedc1c15fdd.tar.gz
gnu: python-openapi-core: Add missing input.
* gnu/packages/python-web.scm (python-openapi-core)[build-system]: Use
pyproject-build-system.
[arguments]: Do not override 'check phase; specify #:test-flags.
[native-inputs]: Add python-mock.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm25
1 files changed, 11 insertions, 14 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b2086fcbb1..0111d5508f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1848,25 +1848,22 @@ compliance with the specification.")
        (sha256
         (base32
          "1npsibyf8zx6z230yl19kyap8g25kqvgm7z1w6rm6jxv58yqsp7r"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
      (list
-      #:phases
-      #~(modify-phases %standard-phases
-          (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
-              (when tests?
-                (invoke "pytest" "-vv" "tests/unit"
-                        ;; Ignore Pytest configuration in setup.cfg that adds
-                        ;; unwanted flake8 and coverage options.
-                        "-c" "/dev/null"
-                        ;; This tests fails due to changes in Pytest; fixed
-                        ;; but not yet released upstream
-                        ;; (https://github.com/p1c2u/openapi-core/issues/158).
-                        "-k" "not test_string_format_invalid_value")))))))
+      #:test-flags
+      '(list "tests/unit"
+             ;; Ignore Pytest configuration in setup.cfg that adds
+             ;; unwanted flake8 and coverage options.
+             "-c" "/dev/null"
+             ;; This tests fails due to changes in Pytest; fixed
+             ;; but not yet released upstream
+             ;; (https://github.com/p1c2u/openapi-core/issues/158).
+             "-k" "not test_string_format_invalid_value")))
     (native-inputs (list python-django
                          python-falcon
                          python-flask
+                         python-mock
                          python-poetry-core
                          python-pypa-build
                          python-pytest