summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-09-11 22:02:40 +0800
committerMarius Bakke <marius@gnu.org>2023-09-22 01:29:17 +0800
commitb2467d2354b8d0b43e53f15d8c349489110a1a97 (patch)
tree44914d856375fab99cce9bcd25ff4880e482feda /gnu/packages/python-web.scm
parent353f58db510ed5c37287c066449d701ec2092656 (diff)
downloadguix-b2467d2354b8d0b43e53f15d8c349489110a1a97.tar.gz
gnu: Add python-html5tagger.
* gnu/packages/python-web.scm (python-html5tagger): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 1b7225c991..f8e040294a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1725,6 +1725,26 @@ C, yielding parse times that can be a thirtieth of the html5lib parse times.")
     ;; indicate ASL2.0, including the LICENSE file for the whole project.
     (license (list license:asl2.0 license:gpl3))))
 
+(define-public python-html5tagger
+  (package
+    (name "python-html5tagger")
+    (version "1.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "html5tagger" version))
+              (sha256
+               (base32
+                "1acd1a4f66gi4plqnsml7cf33qp83mxsnmnqpdwkpj7597xkvyl4"))))
+    (build-system pyproject-build-system)
+    (native-inputs
+     (list python-setuptools-scm))
+    (home-page "https://github.com/sanic-org/html5tagger")
+    (synopsis "Create HTML documents from Python")
+    (description
+     "@code{html5tagger} provides a simplified HTML5 syntax that can
+be written directly in Python without templates.")
+    (license license:unlicense)))
+
 (define-public python-minio
   (package
     (name "python-minio")