summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-27 11:20:56 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-27 12:48:40 +0200
commit474039554de2641966caf5db6aaf6d54c09a5e1b (patch)
tree8fdb7dd3fdc0dfc77f91611468c6a93a1246bd0b /gnu/packages/python-web.scm
parent67eda45bbbadbede356c8ddd49c1aa1bdbccc04f (diff)
downloadguix-474039554de2641966caf5db6aaf6d54c09a5e1b.tar.gz
gnu: python-flask: Run test suite.
* gnu/packages/python-web.scm (python-flask)[arguments]: Use custom
'check phase.
[native-inputs]: Add python-pytest.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 832ca93970..8056c862bd 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1591,6 +1591,14 @@ minimum of WSGI.")
                (base32
                 "0j6f4a9rpfh25k1gp7azqhnni4mb4fgy50jammgjgddw1l3w0w92"))))
     (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (invoke "python" "-m" "pytest"))))))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)))
     (propagated-inputs
      `(("python-itsdangerous" ,python-itsdangerous)
        ("python-jinja2" ,python-jinja2)