summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorChristopher Lemmer Webber <cwebber@dustycloud.org>2020-07-01 16:36:29 -0400
committerChristopher Lemmer Webber <cwebber@dustycloud.org>2020-07-02 08:16:25 -0400
commit054153b28cea697d0439127ffdea4aadfd5c2e0a (patch)
tree47e20501bb54b73cd31da644593cd93b5c6226e7 /gnu/packages/python-web.scm
parentb919d4048e72f8e5740606cdb3dac0592de21f36 (diff)
downloadguix-054153b28cea697d0439127ffdea4aadfd5c2e0a.tar.gz
gnu: python-grequests: Fix tests by adding zope dependencies.
* gnu/packages/python-web.scm (python-grequests)[native-inputs]:
  Add python-zope.interface, python-zope.event.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 030abef9c2..c929e254f7 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2010,7 +2010,9 @@ library.")
      `(("python-gevent" ,python-gevent)
        ("python-requests" ,python-requests)))
     (native-inputs
-     `(("python-nose" ,python-nose)))
+     `(("python-nose" ,python-nose)
+       ("python-zope.interface" ,python-zope-interface)
+       ("python-zope.event" ,python-zope-event)))
     (home-page "https://github.com/kennethreitz/grequests")
     (synopsis "Python library for asynchronous HTTP requests")
     (description "GRequests is a Python library that allows you to use