summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-11 17:12:35 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-11 17:12:54 +0200
commit23a575f97cab5b86a72391dd4ab3b937cd70d8a9 (patch)
tree23a32adb4993a536dc8413629000e727970bbaaf /gnu/packages/python-web.scm
parent6cac909c95b77b58f48b920e49f8802526a3e290 (diff)
downloadguix-23a575f97cab5b86a72391dd4ab3b937cd70d8a9.tar.gz
gnu: Add python-omnipath.
* gnu/packages/python-web.scm (python-omnipath): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c48204b966..1e893723a7 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -119,6 +119,7 @@
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages time)
+  #:use-module (gnu packages version-control)
   #:use-module (gnu packages web)
   #:use-module (gnu packages xml)
   #:use-module ((guix licenses) #:prefix license:)
@@ -1752,6 +1753,54 @@ BOM detection, but the actual implementation for encoders and decoders
 is Python’s.")
     (license license:bsd-3)))
 
+(define-public python-omnipath
+  (package
+    (name "python-omnipath")
+    (version "1.0.6")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "omnipath" version))
+              (sha256
+               (base32
+                "01hmcp1202g5drs8dkxnyyb5v14g503dj4zfiqypghmigi9ipw86"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases
+      '(modify-phases %standard-phases
+         (add-after 'unpack 'relax
+           (lambda _
+             (substitute* "requirements.txt"
+               (("wrapt>=1.12.0")
+                "wrapt>=1.11.0"))))
+         (add-after 'unpack 'set-home
+           (lambda _ (setenv "HOME" "/tmp"))))))
+    (propagated-inputs
+     (list python-attrs
+           python-docrep
+           python-inflect
+           python-networkx
+           python-packaging
+           python-pandas
+           python-requests
+           python-tqdm
+           python-typing-extensions
+           python-urllib3
+           python-wrapt))
+    (native-inputs
+     (list python-bump2version
+           python-pre-commit
+           python-pytest
+           python-pytest-mock
+           python-requests-mock
+           python-setuptools-scm
+           python-tox))
+    (home-page "https://omnipathdb.org/")
+    (synopsis "Python client for the OmniPath web service")
+    (description "This package provides a Python client for the OmniPath web
+service.")
+    (license license:expat)))
+
 (define-public python-openapi-schema-validator
   (package
     (name "python-openapi-schema-validator")