summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-22 00:09:06 +0100
committerMarius Bakke <marius@gnu.org>2022-01-22 10:23:01 +0100
commit404447b74282524947e8415251f0274c52074ba3 (patch)
tree2de06935da544363a178a35c6b3c69fa92a3d91a /gnu/packages/python-web.scm
parentb08151049d5a0324adedad03a78825fc400dd627 (diff)
downloadguix-404447b74282524947e8415251f0274c52074ba3.tar.gz
gnu: Deprecate python-flask-restplus.
* gnu/packages/python-web.scm (python-flask-restplus): Define as deprecated
alias for PYTHON-FLASK-RESTX, as noted on its home page.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm36
1 files changed, 3 insertions, 33 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 0954a72310..232d6f0137 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3466,39 +3466,6 @@ applications.")
      "This package adds SQLAlchemy support to your Flask application.")
     (license license:bsd-3)))
 
-(define-public python-flask-restplus
-  (package
-    (name "python-flask-restplus")
-    (version "0.9.2")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (pypi-uri "flask-restplus" version))
-        (sha256
-          (base32
-            "11his6ii5brpkhld0d5bwzjjw4q3vmplpd6fmgzjrvvklsbk0cf4"))))
-    (build-system python-build-system)
-    (arguments
-     '(#:tests? #f)) ; FIXME: 35/882 tests failing.
-       ;; #:phases
-       ;; (modify-phases %standard-phases
-       ;;   (replace 'check
-       ;;     (lambda _
-       ;;       (invoke "nosetests")
-       ;;       #t)))))
-    (propagated-inputs
-      (list python-aniso8601 python-flask python-jsonschema python-pytz
-            python-six))
-    (native-inputs
-     (list python-tzlocal python-blinker python-nose python-rednose))
-    (home-page "https://github.com/noirbizarre/flask-restplus")
-    (synopsis "Framework for documented API development with Flask")
-    (description "This package provides a framework for API development with
-the Flask web framework in Python.  It is similar to package
-@code{python-flask-restful} but supports the @code{python-swagger}
-documentation builder.")
-    (license license:expat)))
-
 (define-public python-flask-restful-swagger
   (package
     (name "python-flask-restful-swagger")
@@ -5638,6 +5605,9 @@ decorators and tools to describe your API and expose its documentation properly
 Swagger.")
     (license license:bsd-3)))
 
+(define-public python-flask-restplus
+  (deprecated-package "python-flask-restplus" python-flask-restx))
+
 (define-public python-flask-socketio
   (package
     (name "python-flask-socketio")