summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-01-12 23:53:59 +0100
committerJulien Lepiller <julien@lepiller.eu>2020-01-26 18:50:04 +0100
commitad429e0de74eb087097ed383e2cda046321e5dc2 (patch)
tree39f6ba3d669ba4b33dd98d7848732249a14dcf14 /gnu/packages/python-web.scm
parent63f76ab29e69ef503ab1fb5e11255ba2caa02a3c (diff)
downloadguix-ad429e0de74eb087097ed383e2cda046321e5dc2.tar.gz
gnu: Add python-gitlab.
* gnu/packages/python-web.scm (python-gitlab): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 08f4307588..9464021d82 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3469,3 +3469,28 @@ and fairly speedy.")
 the source code of a project.  It supports many translation file formats and
 is part of the Weblate translation platform.")
     (license license:gpl3+)))
+
+(define-public python-gitlab
+  (package
+    (name "python-gitlab")
+    (version "1.15.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "python-gitlab" version))
+        (sha256
+         (base32
+          "0zl6kz8v8cg1bcy2r78b2snb0lpw0b573gdx2x1ps0nhsh75l4j5"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-requests" ,python-requests)
+       ("python-six" ,python-six)))
+    (native-inputs
+     `(("python-httmock" ,python-httmock)
+       ("python-mock" ,python-mock)))
+    (home-page
+      "https://github.com/python-gitlab/python-gitlab")
+    (synopsis "Interact with GitLab API")
+    (description "This package provides an extended library for interacting
+with GitLab instances through their API.")
+    (license license:lgpl3+)))