summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorFabio Natali <me@fabionatali.com>2024-10-09 18:52:26 +0100
committerjgart <jgart@dismail.de>2024-10-10 22:07:11 -0500
commit01db401dc82179f83b38dcc5b393c16db7cdb701 (patch)
tree0c9fe1d8a77af78c7e25febf14add5272e27fb04 /gnu/packages/python-xyz.scm
parent5583d80cbebc14f3a544023829da7068bcbd15e0 (diff)
downloadguix-01db401dc82179f83b38dcc5b393c16db7cdb701.tar.gz
gnu: python-icalendar: Update to 5.0.13.
* gnu/packages/python-xyz.scm (python-icalendar): Update to 5.0.13.
[propagated-inputs]: Add python-tzdata.
[native-inputs]: Add python-pytest, python-pytz.
[synopsis]: Improve the synopsis.
[description]: Improve the description.

Change-Id: Iafa906540df87db84cd4752cb4b345d838bff15c
Signed-off-by: jgart <jgart@dismail.de>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 17 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 38ee4a5908..7eb2498a99 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18517,19 +18517,29 @@ minimal and fast API targeting the following uses:
 (define-public python-icalendar
   (package
     (name "python-icalendar")
-    (version "4.1.0")
+    (version "5.0.13")
     (source (origin
              (method url-fetch)
              (uri (pypi-uri "icalendar" version))
              (sha256
               (base32
-               "15dkq42rkqjdi17rpvmd1plnbwn4daby0nk1s1c3xi7w5v0bfj4p"))))
-    (build-system python-build-system)
+               "01lp0advx60z8wgng8aga1p1668ydn1r6d9qm3d622yfikg9yycj"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (invoke "pytest" "-vv" "src/icalendar/tests")))))))
     (propagated-inputs
-     (list python-dateutil python-pytz))
-    (synopsis "Python library for parsing iCalendar files")
-    (description "The icalendar package is a parser/generator of iCalendar
-files for use with Python.")
+     (list python-dateutil python-pytz python-tzdata))
+    (native-inputs
+     (list python-pytest python-pytz))
+    (synopsis "Python library for parsing and generating iCalendar files")
+    (description
+     "@code{icalendar} is a Python library for parsing and generating iCalendar files.")
     (home-page "https://github.com/collective/icalendar")
     (license license:bsd-2)))