summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorBrett Gilio <brettg@posteo.net>2019-02-07 22:04:52 -0600
committerLudovic Courtès <ludo@gnu.org>2019-02-12 23:30:16 +0100
commit56f4ad47bde0f416b31433a8274e301ceda4bf42 (patch)
treebfb5da68b00b55d6135e16483434f76fe62a965c /gnu/packages/python-xyz.scm
parent346c87522ee5cc10c80bea0b5609c7a7f212537d (diff)
downloadguix-56f4ad47bde0f416b31433a8274e301ceda4bf42.tar.gz
gnu: Add python-docstyle.
* gnu/packages/python-xyz.scm (python-docstyle): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 959b4647cf..55d2c26d45 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2601,6 +2601,29 @@ Language (TOML) configuration files.")
      "This packages provides a JSON RPC 2.0 server library for Python.")
     (license license:expat)))
 
+(define-public python-pydocstyle
+  (package
+    (name "python-pydocstyle")
+    (version "3.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pydocstyle" version))
+       (sha256
+        (base32
+         "1m1xv9clkg9lgzyza6dnj359z04vh5g0h49nhzghv7lg81gchhap"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-six" ,python-six)
+       ("python-snowballstemmer" ,python-snowballstemmer)))
+    (home-page
+     "https://github.com/PyCQA/pydocstyle/")
+    (synopsis "Python docstring style checker")
+    (description
+     "This package provides a style checker for the Python Language
+Server (PLS).")
+    (license license:expat)))
+
 (define-public python-black
   (package
     (name "python-black")