summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-09 22:44:10 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-30 10:30:48 +0100
commit71c5db87694812add83633f8ac9332fd9b3fe59b (patch)
treea3a157dbf9ec66237defd17f64292e2387e6a681 /gnu/packages/python-xyz.scm
parent27172c4f5013fe6d7107da340bcb6c3b20d62646 (diff)
downloadguix-71c5db87694812add83633f8ac9332fd9b3fe59b.tar.gz
gnu: Add python-echo.
* gnu/packages/python-xyz.scm (python-echo): New variable.

Change-Id: Id506a7b4ed9681227372455f9d96a0957eb845a7
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7aaddae2a3..3e97c5a269 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2382,6 +2382,42 @@ EasyGUI is NOT event-driven.  Instead, all GUI interactions are invoked by
 simple function calls.")
     (license license:bsd-3)))
 
+(define-public python-echo
+  (package
+    (name "python-echo")
+    (version "0.8.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "echo" version))
+       (sha256
+        (base32 "1hr2kgjmf5gcjbg1mry03ca1dayfwy8mi8as42jfg0apsa3bfvvj"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'start-xorg-server
+            (lambda _
+              ;; The test suite requires a running X server.
+              (system "Xvfb :99 -screen 0 1024x768x24 &")
+              (setenv "DISPLAY" ":99.0"))))))
+    (propagated-inputs
+     (list python-numpy
+           python-qtpy
+           python-pyqt-6))
+    (native-inputs
+     (list python-pytest
+           python-pytest-cov
+           python-setuptools-scm
+           xorg-server-for-tests))
+    (home-page "https://github.com/glue-viz/echo")
+    (synopsis "Callback Properties in Python")
+    (description
+     "Echo is a small library for attaching callback functions to property
+state changes.")
+    (license license:expat)))
+
 (define-public python-pymd4c
   (package
     (name "python-pymd4c")