summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-01 21:10:04 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-01 21:10:04 +0000
commita9abf9a7b30f6801e122cae759df87b44c458773 (patch)
tree21b5ced581d021a7976643801eb19be9d93c39d7 /gnu/packages/python-xyz.scm
parentcd9ac7d96b3634a7e1ec8da988dd3ac2dd186018 (diff)
downloadguix-a9abf9a7b30f6801e122cae759df87b44c458773.tar.gz
gnu: python-dbus-python: Fix indentation.
* gnu/packages/python-xyz.scm (python-dbus-python): Fix indentation,
adjust order of fields, sort inputs alphabetically.

Change-Id: I895518f041bd2cfc9c2f94774a9d1db47b26ffc3
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm69
1 files changed, 39 insertions, 30 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c01e6d799b..eb5bad622a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30063,36 +30063,45 @@ for YAML and JSON.")
 
 (define-public python-dbus-python
   (package
-  (name "python-dbus-python")
-  (version "1.3.2")
-  (source
-   (origin
-     (method url-fetch)
-     (uri (pypi-uri "dbus-python" version))
-     (sha256
-      (base32 "1y28h90v2ib8zqhs3r2yr7ycg8ccwvw3gqkvadlm12v1129q2rxd"))))
-  (build-system pyproject-build-system)
-  (arguments
-   (list #:phases #~(modify-phases %standard-phases
-                      (add-after 'unpack 'patch-requirements
-                        (lambda _
-                          (substitute* (list "pyproject.toml" "setup.py")
-                            (("'(ninja|patchelf)',?") ""))
-                          (substitute* "setup.cfg"
-                            (("(ninja|patchelf)") "")))))))
-  (inputs (list dbus glib))
-  (propagated-inputs (list python-pygobject))
-  (native-inputs (list pkg-config
-                       python-meson-python
-                       meson ninja patchelf
-                       python-sphinx python-sphinx-rtd-theme
-                       python-tappy
-                       python-wheel))
-  (home-page "https://dbus.freedesktop.org/doc/dbus-python/")
-  (synopsis "Python bindings for libdbus")
-  (description "This package provides Python bindings to libdbus, the
-reference implementation of the D-Bus protocol.")
-  (license license:expat)))
+    (name "python-dbus-python")
+    (version "1.3.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "dbus-python" version))
+       (sha256
+        (base32 "1y28h90v2ib8zqhs3r2yr7ycg8ccwvw3gqkvadlm12v1129q2rxd"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'patch-requirements
+            (lambda _
+              (substitute* (list "pyproject.toml" "setup.py")
+                (("'(ninja|patchelf)',?") ""))
+              (substitute* "setup.cfg"
+                (("(ninja|patchelf)") "")))))))
+    (native-inputs
+     (list meson
+           pkg-config
+           ninja
+           patchelf
+           python-meson-python
+           python-sphinx
+           python-sphinx-rtd-theme
+           python-tappy
+           python-wheel))
+    (inputs
+     (list dbus glib))
+    (propagated-inputs
+     (list python-pygobject))
+    (home-page "https://dbus.freedesktop.org/doc/dbus-python/")
+    (synopsis "Python bindings for libdbus")
+    (description
+     "This package provides Python bindings to libdbus, the reference
+implementation of the D-Bus protocol.")
+    (license license:expat)))
 
 (define-public python-dbusmock
   (package