summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSören Tempel <soeren@soeren-tempel.net>2024-09-27 20:34:59 +0200
committerLudovic Courtès <ludo@gnu.org>2024-10-07 12:51:24 +0200
commitceea675a09e2bed3ff772a481c23e9d6e432c61b (patch)
tree0b2941ada58e9a82716a4bc2bd1332f1ea61cb64 /gnu/packages/python-xyz.scm
parentcb79f3b1ccd100d072e793bc568c765e643d64dd (diff)
downloadguix-ceea675a09e2bed3ff772a481c23e9d6e432c61b.tar.gz
gnu: python-cle: Update to 9.2.112.
* gnu/packages/python-xyz.scm (python-cle): Update to 9.2.112.
[propagated-inputs]: Add python-cart.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1ecd17b487..5f831afc94 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -34119,19 +34119,19 @@ binary analysis platform.")
   (package
     (name "python-cle")
     ;; Must be the same version as python-angr.
-    (version "9.2.46")
+    (version "9.2.112")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "cle" version))
        (sha256
-        (base32 "0mswv9gd2p2ws7zfsshqv5ybbj27wkdwakdcknq4vsrx9ry9k4yc"))))
+        (base32 "11jbvg12wqxz74iy83ax0q8k156xrw6iqv75dix5cpqgacds3gdj"))))
     (build-system pyproject-build-system)
     (arguments
      (list
       #:tests? #f))
     (propagated-inputs (list python-pefile python-pyelftools python-pyvex
-                             python-sortedcontainers))
+                             python-sortedcontainers python-cart))
     (native-inputs (list python-cffi))
     (home-page "https://github.com/angr/cle")
     (synopsis "Python loader for binaries and their associated libraries")