summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2022-09-10 12:29:42 +0000
committerMathieu Othacehe <othacehe@gnu.org>2022-09-11 16:43:30 +0200
commitef49ec6d68b6338ea816636479cbcfb48c387bd8 (patch)
treece4d99e3fac52afc0cbb93a85881c33d69ef857b /gnu/packages/python-xyz.scm
parent4b32f87e9adf91d5d94287562d8844727d47a07b (diff)
downloadguix-ef49ec6d68b6338ea816636479cbcfb48c387bd8.tar.gz
gnu: python-qrcode: Update to 7.3.1.
* gnu/packages/python-xyz.scm (python-qrcode): Update to 7.3.1.
[propagated-inputs]: Remove python-six.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ed44c53f38..6a9122f1d5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18825,21 +18825,20 @@ from the header, as well as section details and data available.")
 (define-public python-qrcode
   (package
     (name "python-qrcode")
-    (version "6.1")
+    (version "7.3.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "qrcode" version))
        (sha256
-        (base32 "0sa3n298b9jpz6zn0birnjii3mg9sihjq28n9nzjlzv09y2m6ljh"))))
+        (base32 "0y35jlwfvkgn9341lzshyaqgpp61vysjh107vhdd96ya83r6ynip"))))
     (build-system python-build-system)
     (arguments
      ;; FIXME: Tests require packaging 'pymaging'.
      '(#:tests? #f))
     (propagated-inputs
      (list python-lxml ; for SVG output
-           python-pillow ; for PNG output
-           python-six))
+           python-pillow)) ; for PNG output
     (home-page "https://github.com/lincolnloop/python-qrcode")
     (synopsis "QR Code image generator")
     (description "This package provides a pure Python QR Code generator