summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2023-06-20 14:06:11 +0000
committerChristopher Baines <mail@cbaines.net>2023-07-10 12:39:35 +0100
commitb7be0a999df8984fee8bd9d283b8fbe7e4da879d (patch)
tree5502c40d963f382114594d407c9076e19365130d /gnu/packages/python-xyz.scm
parent6d2ca5dd045b64cc885714cee14c875f4507180d (diff)
downloadguix-b7be0a999df8984fee8bd9d283b8fbe7e4da879d.tar.gz
gnu: bpython: Update to 0.24.
* gnu/packages/python-xyz.scm (bpython): Update to 0.24.
[propagated-inputs]: Remove python-six.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3cd29e9bce..9f43eff03d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23914,13 +23914,13 @@ with PEP 484 argument (and return) type annotations.")
 (define-public bpython
   (package
     (name "bpython")
-    (version "0.23")
+    (version "0.24")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "bpython" version))
        (sha256
-        (base32 "0ah5giynavyh70yc0jqgmjaajv3xg5j2y7k9i3q8mi47r2mph04z"))))
+        (base32 "1g9xzl49skghd9q2a8b71gg1n97lfnj9in2kzcmzsj4cgbynywwq"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -23945,7 +23945,6 @@ with PEP 484 argument (and return) type annotations.")
            python-requests
            python-curtsies
            python-greenlet
-           python-six
            python-cwcwidth
            python-pyxdg
            ;; optional dependencies