summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-06-01 15:01:27 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-06-01 20:48:17 +0200
commiteb2918aa96b74e45b35d18a209860f4a2d13ad68 (patch)
tree785f600f29d1a24b859e66917f7e65b5a9d11b73 /gnu/packages/python-xyz.scm
parentd411b7d5e7b17f1add3ea8df22560aea6e27c248 (diff)
downloadguix-eb2918aa96b74e45b35d18a209860f4a2d13ad68.tar.gz
gnu: Add python-plotext.
* gnu/packages/python-xyz.scm (python-plotext): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 25d69b5d0c..cf462cc07f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1114,6 +1114,23 @@ allows arithmetic operations between them and conversions from and to
 different units.")
     (license license:bsd-3)))
 
+(define-public python-plotext
+  (package
+    (name "python-plotext")
+    (version "5.2.8")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "plotext" version))
+              (sha256
+               (base32
+                "1gpy1z2i4vq1mcrhysxahz4339pbl9rzk58rf5m5gf5ym9xji6ii"))))
+    (build-system pyproject-build-system)
+    (arguments (list #:tests? #false)) ;there are none
+    (home-page "https://github.com/piccolomo/plotext")
+    (synopsis "Plots in the terminal")
+    (description "Plotext lets you plot directly to the terminal.")
+    (license license:expat)))
+
 (define-public python-plotille
   (package
     (name "python-plotille")