summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2022-08-15 11:06:53 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-08-15 11:08:05 +0200
commit6b2d29a6f53a9fe0be72953611f9f910b871d9af (patch)
tree39171845a5db60dd69eec7b3016c2b2cea810c03 /gnu/packages/python-xyz.scm
parent2e88164023cad397fecac023cc7855b3ad1d84b6 (diff)
downloadguix-6b2d29a6f53a9fe0be72953611f9f910b871d9af.tar.gz
Revert "gnu: python-lsp-server: Update to 1.5.0."
This reverts commit 07f807f12c0949e9deeee09b4a28bb1f810b26ca because it
requires a python-pluggy update which seems to cause some issues.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 15 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5e8a3654ab..5d492d073c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5273,19 +5273,30 @@ Server (PLS).")
 (define-public python-lsp-server
   (package
     (name "python-lsp-server")
-    (version "1.5.0")
+    (version "1.3.3")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "python-lsp-server" version))
        (sha256
         (base32
-         "039qi5x9sa1mjzinimxhiwzj8lxn5d5l33q6qhkjl0i5k70r9h75"))))
+         "0h6wxzmm6qjfwkkn3mnzn1fpmcp23fpbk74bi8p540q1nzccqj0v"))))
     (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'set-HOME
+           (lambda _ (setenv "HOME" "/tmp")))
+         (replace 'check
+           (lambda _
+             ;; Disable failing test.
+             (invoke "python" "-m" "pytest" "-k"
+                     "not test_pyqt_completion"))))))
     (propagated-inputs
      (list python-autopep8
            python-pydocstyle
            python-flake8
+           python-future
            python-jedi
            python-lsp-jsonrpc
            python-pluggy
@@ -5298,12 +5309,13 @@ Server (PLS).")
      (list python-coverage
            python-flaky
            python-matplotlib
+           python-mock
            python-numpy
            python-pandas
            python-pylint
            python-pytest
            python-pytest-cov
-           python-whatthepatch))
+           python-versioneer))
     (home-page "https://github.com/python-lsp/python-lsp-server")
     (synopsis "Python implementation of the Language Server Protocol")
     (description