summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-02 16:24:15 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-04 22:33:19 +0100
commitc6a2fd24fcb956dfaf4d155b0fca0e4e9c5def6b (patch)
tree54e54694ba18ef06a0a1d0279ebd4e6b8ca4e000 /gnu/packages/python-xyz.scm
parent80893da589df84ff2a9b463dca001642f8278359 (diff)
downloadguix-c6a2fd24fcb956dfaf4d155b0fca0e4e9c5def6b.tar.gz
gnu: python-cython: Update to 0.29.6.
* gnu/packages/python-xyz.scm (python-cython): Update to 0.29.6.
[arguments]: Remove obsolete deletion.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 09c7e2db38..6a20ba4b49 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2802,14 +2802,14 @@ and is very extensible.")
 (define-public python-cython
   (package
     (name "python-cython")
-    (version "0.29.5")
+    (version "0.29.6")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "Cython" version))
        (sha256
         (base32
-         "1wfb68g115gmf3mv23w0hh972b0ll85gpb92ci28x6h997br0llx"))))
+         "1bp7cn0pp5qy63k9hbp4ka34fm01kvysh478phpkhr68npqk6pbc"))))
     (build-system python-build-system)
     ;; we need the full python package and not just the python-wrapper
     ;; because we need libpython3.3m.so
@@ -2841,9 +2841,6 @@ and is very extensible.")
 
          (replace 'check
            (lambda _
-             ;; The "with_outer_raising" test fails with Python 3.7.  See
-             ;; https://github.com/cython/cython/issues/2454
-             (delete-file "tests/run/generators_py.py")
              (invoke "python" "runtests.py" "-vv"))))))
     (home-page "http://cython.org/")
     (synopsis "C extensions for Python")