summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2022-12-05 21:20:04 -0300
committerVinicius Monego <monego@posteo.net>2023-02-05 09:39:11 -0300
commitcd0ae604f4dcb3799c23c9332cc463eb1a04957c (patch)
tree53fe075006bbd5bd6192ef4d69da26e5a3f65d1c /gnu/packages/python-xyz.scm
parent39e80baafce41a7e8ae516953625f27e2f087f57 (diff)
downloadguix-cd0ae604f4dcb3799c23c9332cc463eb1a04957c.tar.gz
gnu: python-janus: Update to 1.0.0.
* gnu/packages/python-xyz.scm (python-janus): Update to 1.0.0.
[build-system]: Switch to pyproject-build-system.
[arguments]: Don't override the 'check phase.
[propagated-inputs]: Add python-typing-extensions.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 4 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index de71c48d84..1866f9c920 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -291,24 +291,17 @@ similar XML files, in the same way the @command{diff} utility does it.")
 (define-public python-janus
   (package
     (name "python-janus")
-    (version "0.6.1")
+    (version "1.0.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "janus" version))
        (sha256
-        (base32 "030xvl2vghi5ispfalhvch1rl6i2jsy5bf1dgjafa7vifppy04j7"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? inputs outputs #:allow-other-keys)
-             (when tests?
-               (add-installed-pythonpath inputs outputs)
-               (invoke "pytest" "--cov=janus" "--cov=tests")))))))
+        (base32 "04hnrdcf03g1s0x3sr72sh9gnszz6kyfsl9dg8a4n0zvvhn6z5yz"))))
+    (build-system pyproject-build-system)
     (native-inputs
      (list python-pytest python-pytest-cov python-pytest-asyncio))
+    (propagated-inputs (list python-typing-extensions))
     (home-page "https://github.com/aio-libs/janus/")
     (synopsis
      "Sync-async queue to interoperate between asyncio tasks and classic threads")