summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-26 22:12:32 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-26 22:12:32 +0200
commit18786ae50272627a665a160bc5becc587957d8a3 (patch)
tree78b41dcba6c3cb1ae158f4498ef4290834902cb9 /gnu/packages/python-xyz.scm
parent182fbbb0094452ffed2bf2984a0d57ca12197265 (diff)
downloadguix-18786ae50272627a665a160bc5becc587957d8a3.tar.gz
gnu: python-fastjsonschema: Use pyproject-build-system.
* gnu/packages/python-xyz.scm (python-fastjsonschema): Reindent.
[build-system]: Use pyproject-build-system.
[arguments]: Remove custom check phase; update comment on why tests are
disabled.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm41
1 files changed, 17 insertions, 24 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 97f2f8613a..0abfa226f4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13998,34 +13998,27 @@ significantly better performance.")
     (name "python-fastjsonschema")
     (version "2.15.1")
     (source
-      (origin
-        (method url-fetch)
-        (uri (pypi-uri "fastjsonschema" version))
-        (sha256
-          (base32 "1ln2j60jzyn6p8i8ljygfgrji58hc23452g7nllkcjdk4p93c7v7"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:tests? #f ; Fail with a strange backtrace ending in importlib.
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
-            (when tests?
-              (invoke "pytest" "-vv" "-m" "not benchmark")))))))
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "fastjsonschema" version))
+       (sha256
+        (base32 "1ln2j60jzyn6p8i8ljygfgrji58hc23452g7nllkcjdk4p93c7v7"))))
+    (build-system pyproject-build-system)
+    (arguments `(#:tests? #f))          ;no tests included
     (native-inputs
-      (list python-colorama
-            python-json-spec
-            python-jsonschema
-            python-pylint
-            python-pytest
-            python-pytest-benchmark
-            python-pytest-cache))
+     (list python-colorama
+           python-json-spec
+           python-jsonschema
+           python-pylint
+           python-pytest
+           python-pytest-benchmark
+           python-pytest-cache))
     (home-page
-      "https://github.com/horejsek/python-fastjsonschema")
+     "https://github.com/horejsek/python-fastjsonschema")
     (synopsis
-      "Fast Python implementation of JSON schema")
+     "Fast Python implementation of JSON schema")
     (description
-      "This library implements validation of JSON documents by JSON schema for
+     "This library implements validation of JSON documents by JSON schema for
 drafts 04, 06 and 07.")
     (license license:bsd-3)))