summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-06-14 12:08:04 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-06-14 14:52:23 +0300
commit3573c82747b2f3ec85cc8345146fa0d7f92cb76a (patch)
tree2844bd0b7b7ec3d05d6928494aaf65a91610bb10 /gnu/packages/python-xyz.scm
parent071ee5856d00e22ea9e289e4a7cebe80a7871b06 (diff)
downloadguix-3573c82747b2f3ec85cc8345146fa0d7f92cb76a.tar.gz
gnu: python-blosc: Update to 1.11.1.
* gnu/packages/python-xyz.scm (python-blosc): Update to 1.11.1.
[source]: Update snippet.
[arguments]: Adjust custom 'find-blosc phase.
[propagated-inputs]: Add python-scikit-build.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3be2d0dae5..86665b0af4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25230,17 +25230,17 @@ they use the same path.")
 (define-public python-blosc
   (package
     (name "python-blosc")
-    (version "1.5.1")
+    (version "1.11.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "blosc" version))
        (sha256
         (base32
-         "1cm91c6r431yla2mbs4895bgiianjf30dfz14vvv99dslygd65jw"))
+         "0xmjs28sgpnb940zrhw010dq2m9d8a5h4fgnjyk6645fgfr1j8f2"))
        (snippet
         #~(begin (use-modules (guix build utils))
-                 (delete-file-recursively "c-blosc")))))
+                 (delete-file-recursively "blosc/c-blosc")))))
     (build-system python-build-system)
     ;; FIXME: all tests pass, but then this error is printed:
     ;; TypeError: calling <function run at 0x7ffff2568d90> returned None, not a test
@@ -25250,9 +25250,10 @@ they use the same path.")
            #~(modify-phases %standard-phases
                (add-after 'unpack 'find-blosc
                  (lambda* (#:key inputs #:allow-other-keys)
-                   (setenv "BLOSC_DIR" #$(this-package-input "c-blosc")))))))
+                   (setenv "USE_SYSTEM_BLOSC" "1")
+                   (setenv "Blosc_ROOT" #$(this-package-input "c-blosc")))))))
     (propagated-inputs
-     (list python-numpy))
+     (list python-scikit-build python-numpy))
     (inputs (list c-blosc))
     (home-page "https://github.com/blosc/python-blosc")
     (synopsis "Python wrapper for the Blosc data compressor library")