summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-06-27 17:07:22 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-06-29 12:01:22 +0200
commitb68bf7d3da368b0a3d330942432892e846d9d74d (patch)
tree2ccb3c071b6b63348a51584fd5b08b11948f9040 /gnu/packages/python-xyz.scm
parenta4aadeef9ce1cdfc7baf057454255b47a54d67b3 (diff)
downloadguix-b68bf7d3da368b0a3d330942432892e846d9d74d.tar.gz
gnu: Add python-affine.
* gnu/packages/python-xyz.scm (python-affine): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4a8a3acf10..c6a9e07d49 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -665,6 +665,26 @@ of their positions to minimize overlaps (relatively easy).  This library
 implements the latter option to help with matplotlib graphs.")
     (license license:expat)))
 
+(define-public python-affine
+  (package
+    (name "python-affine")
+    (version "2.4.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "affine" version))
+              (sha256
+               (base32
+                "1shyvajayyzbkp9dihb4mz835jnkp0kqqbyjfqci6v43da6q2kd2"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-coveralls python-flake8 python-pydocstyle
+                             python-pytest python-pytest-cov))
+    (native-inputs (list python-flit-core))
+    (home-page "https://github.com/rasterio/affine")
+    (synopsis "Matrices describing affine transformation of the plane")
+    (description "This is a package for matrices describing the affine
+transformation of the plane.")
+    (license license:bsd-3)))
+
 (define-public python-argopt
   (package
    (name "python-argopt")