summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-06-05 20:22:01 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-06-05 21:36:09 +0300
commitcad86f8dcdbb538bc5d00bae7333a0d07fd37365 (patch)
treeb48ec04784e82e4b96acd71f9f1042832e0faada /gnu/packages/python-xyz.scm
parent5cf38fb6d6f4ab68cff5d58a91d7907a0b9f1327 (diff)
downloadguix-cad86f8dcdbb538bc5d00bae7333a0d07fd37365.tar.gz
gnu: python-codespell: Update to 2.2.4.
* gnu/packages/python-xyz.scm (python-codespell): Update to 2.2.4.
[build-system]: Switch to pyproject-build-system.
[native-inputs]: Remove python-check-manifest; add python-pygments and
python-tomli.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e6a7367557..6413906530 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17230,19 +17230,23 @@ checking library.")
 (define-public python-codespell
   (package
     (name "python-codespell")
-    (version "2.1.0")
+    (version "2.2.4")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "codespell" version))
         (sha256
-          (base32 "1r9y714cz8m894rxp7pyvicr1lw2iid24vz6fxbl5wzy8ibgxlqr"))))
-    (build-system python-build-system)
+          (base32 "0fp8ihlj8q23qdfryj5pq8srl85vn8k8p6gq3zg9qz957i3j0ihb"))))
+    (build-system pyproject-build-system)
     (inputs
       (list python-chardet))
     (native-inputs
-      (list python-check-manifest python-flake8 python-pytest
-            python-pytest-cov python-pytest-dependency))
+      (list python-flake8
+            python-pygments
+            python-pytest
+            python-pytest-cov
+            python-pytest-dependency
+            python-tomli))
     (arguments
      `(#:phases
        (modify-phases %standard-phases