summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-06-14 12:38:01 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-06-14 12:52:53 -0400
commitee7b06e2124337e4bfd253f1678615c6790df8bf (patch)
tree584e067a922c8eb77b229a7161e699dcd8e4dd9c /gnu/packages/python-xyz.scm
parent8f0698dde351790e0bc9e905e4cd71902fd55d5f (diff)
downloadguix-ee7b06e2124337e4bfd253f1678615c6790df8bf.tar.gz
gnu: python-pyzmq: Use pytest to run the test suite.
* gnu/packages/python-xyz.scm (python-pyzmq)
[arguments]: Precise comments regarding #:tests?.  Override check phase.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index afd3100a6b..2bb0dc5a70 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11847,16 +11847,19 @@ applications.")
              ;; FIXME: The test_draft.TestDraftSockets test fails with:
              ;;   zmq.error.Again: Resource temporarily unavailable
              (delete-file "zmq/tests/test_draft.py")
-             ;; These tests fail for unknown reasons (see:
+             ;; These tests appear to depend on a working name resolver (see:
              ;; https://github.com/zeromq/pyzmq/issues/1853).
              (delete-file "zmq/tests/test_auth.py")
              (delete-file "zmq/tests/test_zmqstream.py")))
          (add-before 'check 'build-extensions
            (lambda _
              ;; Cython extensions have to be built before running the tests.
-             (invoke "python" "setup.py" "build_ext" "--inplace"))))))
-    (inputs
-     (list zeromq))
+             (invoke "python" "setup.py" "build_ext" "--inplace")))
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "pytest" "-vv")))))))
+    (inputs (list zeromq))
     (native-inputs
      (list pkg-config
            python-cython