summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2023-03-21 13:52:57 +0100
committerLars-Dominik Braun <ldb@leibniz-psychology.org>2023-03-21 13:56:44 +0100
commit4e5001f915e491e07bfce1c3bfecea0223495e4d (patch)
tree629ffeb4d090b4259ed73df5de0fbd30a80852e2 /gnu/packages/python-xyz.scm
parent31cdb037047bac0ec60c09663f40bf79ab9aceff (diff)
downloadguix-4e5001f915e491e07bfce1c3bfecea0223495e4d.tar.gz
gnu: Add python-markdown-strings.
* gnu/packages/python-xyz.scm (python-markdown-strings): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index abe4862121..ac10290237 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31946,6 +31946,27 @@ functions
 @end itemize")
     (license license:bsd-3)))
 
+(define-public python-markdown-strings
+  (package
+    (name "python-markdown-strings")
+    (version "3.3.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/awesmubarak/markdown_strings.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0064ni7s3k8hqw61wi9m31icxp61f8adhija2qsp46hclcwx7vz2"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-lxml python-six))
+    (home-page "https://github.com/awesmubarak/markdown_strings")
+    (synopsis "Python library to create markdown-formatted text")
+    (description "This package allows the programmatic creation of
+markdown-compliant strings.")
+    (license license:expat)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar