summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-13 18:51:16 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-13 18:51:16 +0200
commite9194eb04896165f15830862c42673e96bc5c5f7 (patch)
tree4f95231aff0267c468560f2ae3c45ed391d16e0f /gnu/packages/python-xyz.scm
parentda460865074bf3cc3b3c51e7678909e7e755787a (diff)
downloadguix-e9194eb04896165f15830862c42673e96bc5c5f7.tar.gz
gnu: python-cython: Speed up test suite.
* gnu/packages/python-xyz.scm (python-cython)[arguments]: In the CHECK phase,
disable compiler optimizations and enable (some) parallel tests.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 943ffdd4cc..a60e1c7e2a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3229,7 +3229,12 @@ provides additional functionality on the produced Mallard documents.")
 
          (replace 'check
            (lambda _
-             (invoke "python" "runtests.py" "-vv"))))))
+             ;; Disable compiler optimizations to greatly reduce the running
+             ;; time of the test suite.
+             (setenv "CFLAGS" "-O0")
+
+             (invoke "python" "runtests.py" "-vv"
+                     "-j" (number->string (parallel-job-count))))))))
     (home-page "https://cython.org/")
     (synopsis "C extensions for Python")
     (description "Cython is an optimising static compiler for both the Python