summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-01 03:15:11 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:56 -0400
commit405a7b3f47d54ce794b6bf1506547bb722e6d46e (patch)
tree8697cf66c348350e035111c66d7ce2ed15756950 /gnu/packages/python-xyz.scm
parent206c05deadb3113632b759bd613d80c246d72122 (diff)
downloadguix-405a7b3f47d54ce794b6bf1506547bb722e6d46e.tar.gz
gnu: Remove python2-typing.
* gnu/packages/python-xyz.scm (python2-typing): Delete variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 0 insertions, 22 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3a92429b96..b67dbaad91 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21087,28 +21087,6 @@ Python 3.6+ type hints.")
 with PEP 484 argument (and return) type annotations.")
     (license license:expat)))
 
-(define-public python2-typing
-  (package
-    (name "python2-typing")
-    (version "3.10.0.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "typing" version))
-       (sha256
-        (base32 "0c5il4d68fd4qrm5k3dps70j0xz0n5krj6lhwn9vzpal3whsvd0k"))))
-    (build-system python-build-system)
-    (arguments (list #:python python-2))
-    (home-page "https://docs.python.org/3/library/typing.html")
-    (synopsis "Type hints for Python")
-    (description "This is a backport of the standard library @code{typing}
-module to Python versions older than 3.5.  Typing defines a standard notation
-for Python function and variable type annotations.  The notation can be used
-for documenting code in a concise, standard format, and it has been designed
-to also be used by static and runtime type checkers, static analyzers, IDEs
-and other tools.")
-    (license license:psfl)))
-
 (define-public python-typing-extensions
   (package
     (name "python-typing-extensions")