summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorKyle Meyer <kyle@kyleam.com>2020-12-08 02:46:40 +0000
committerLudovic Courtès <ludo@gnu.org>2020-12-14 12:20:06 +0100
commit7a8a4fd7a73f81d99e293ae9f2c70357524beba1 (patch)
tree3fbfe0c2aba098484195f66aa9901cd53090eabb /gnu/packages/python-xyz.scm
parentbff6e01afee13c77fa774752405b2e7194ee8092 (diff)
downloadguix-7a8a4fd7a73f81d99e293ae9f2c70357524beba1.tar.gz
gnu: python-dnspython: Update to 2.0.0.
* gnu/packages/python-xyz.scm (python-dnspython): Update to 2.0.0.
[source]: Download from pypi.
[native-inputs]: Add unzip.
[home-page]: Prefer https.
(python-dnspython-1.16):
(python2-dnspython-1.16): New variables.
* gnu/packages/ebook.scm (calibre):
* gnu/packages/web.scm (linkchecker): Use python2-dnspython-1.16.
* gnu/packages/finance.scm (electrum): Use python-dnspython-1.16.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 21 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c650c582d5..53f4f83f14 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15,7 +15,7 @@
 ;;; Copyright © 2015, 2017 Ben Woodcroft <donttrustben@gmail.com>
 ;;; Copyright © 2015, 2016 Erik Edrosa <erik.edrosa@gmail.com>
 ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2015, 2017 Kyle Meyer <kyle@kyleam.com>
+;;; Copyright © 2015, 2017, 2020 Kyle Meyer <kyle@kyleam.com>
 ;;; Copyright © 2015, 2016 Chris Marusich <cmmarusich@gmail.com>
 ;;; Copyright © 2016 Danny Milosavljevic <dannym+a@scratchpost.org>
 ;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
@@ -13353,17 +13353,17 @@ until the object is actually required, and caches the result of said call.")
 (define-public python-dnspython
   (package
     (name "python-dnspython")
-    (version "1.16.0")
+    (version "2.0.0")
     (source (origin
               (method url-fetch)
-              (uri (string-append "http://www.dnspython.org/kits/"
-                                  version "/dnspython-" version ".tar.gz"))
+              (uri (pypi-uri "dnspython" version ".zip"))
               (sha256
                (base32
-                "1yaw7irazy42n0kdhlk7wyg8ki34rxcnc5xbc1wfwy245b0wbxab"))))
+                "1dyip5ygqqhrgcaiy7qzjpndl9xciip186paxqwkm726fj9z0jh4"))))
     (build-system python-build-system)
+    (native-inputs `(("unzip" ,unzip)))
     (arguments '(#:tests? #f))          ; XXX: requires internet access
-    (home-page "http://www.dnspython.org")
+    (home-page "https://www.dnspython.org")
     (synopsis "DNS toolkit for Python")
     (description
      "dnspython is a DNS toolkit for Python.  It supports almost all record
@@ -13371,8 +13371,21 @@ types.  It can be used for queries, zone transfers, and dynamic updates.
 It supports TSIG authenticated messages and EDNS0.")
     (license license:expat)))
 
-(define-public python2-dnspython
-  (package-with-python2 python-dnspython))
+(define-public python-dnspython-1.16
+  (package
+    (inherit python-dnspython)
+    (version "1.16.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://www.dnspython.org/kits/"
+                                  version "/dnspython-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1yaw7irazy42n0kdhlk7wyg8ki34rxcnc5xbc1wfwy245b0wbxab"))))
+    (native-inputs '())))
+
+(define-public python2-dnspython-1.16
+  (package-with-python2 python-dnspython-1.16))
 
 (define-public python-py3dns
   (package