summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 17:41:34 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:52:42 -0400
commite75781ce7aabc96c1120680de8ff684c26b8a964 (patch)
treecd97e6172ea966c694f7b2a7951a15fc34abe49f /gnu/packages/python-xyz.scm
parentfa94ed517368f9babc55375c758ea9e58b94bfcb (diff)
downloadguix-e75781ce7aabc96c1120680de8ff684c26b8a964.tar.gz
gnu: Remove python2-activepapers.
* gnu/packages/python-xyz.scm (python2-activepapers): Delete variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 0 insertions, 17 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 286563ad9c..4e2d615c8d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22290,25 +22290,8 @@ Time} values as well as an event scheduler.")
 combine data, code, and documentation in single-file packages,
 suitable for publication as supplementary material or on repositories
 such as figshare or Zenodo.")
-    (properties `((python2-variant . ,(delay python2-activepapers))))
     (license license:bsd-3)))
 
-(define-public python2-activepapers
-  (let ((base (package-with-python2
-               (strip-python2-variant python-activepapers))))
-    (package/inherit base
-      (arguments
-       (substitute-keyword-arguments (package-arguments base)
-         ((#:phases phases)
-          `(modify-phases ,phases
-             (delete 'delete-python2-code)
-             (add-after 'unpack 'delete-python3-code
-               (lambda _
-                 (for-each delete-file
-                           '("lib/activepapers/builtins3.py"
-                             "lib/activepapers/standardlib3.py"
-                             "lib/activepapers/utility3.py")))))))))))
-
 (define-public python-semver
   (package
     (name "python-semver")