summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-12 22:53:46 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-12 22:53:46 +0200
commit206815b796808874523dc3f928943c423b104f98 (patch)
treee3db50cf791e74d0383239905c64b52504c7fb5f /gnu/packages/python-xyz.scm
parente4ca1bcea53127f4daa358691e46934e70fb908b (diff)
downloadguix-206815b796808874523dc3f928943c423b104f98.tar.gz
gnu: shrinkwrap: Use pyproject-build-system.
* gnu/packages/python-xyz.scm (shrinkwrap)[arguments]: Remove.
[build-system]: Use pyproject-build-system.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 1 insertions, 18 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 30769e4966..1710a303c1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -32861,24 +32861,7 @@ Storage}.")
               (sha256
                (base32
                 "1f3qrygj16y767q2c7pn9j6m95ggcmj9s5cx9v92ygygly4mr3jp"))))
-    (build-system python-build-system)
-    (arguments
-     (list
-      #:phases
-      #~(modify-phases %standard-phases
-          (replace 'check
-            (lambda* (#:key tests? #:allow-other-keys)
-              (when tests?
-                (invoke "pytest" "-v" "tests"))))
-          ;; XXX: PEP 517 manual build copied from python-isort.
-          (replace 'build
-            (lambda _
-              (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
-          (replace 'install
-            (lambda _
-              (let ((whl (car (find-files "dist" "\\.whl$"))))
-                (invoke "pip" "--no-cache-dir" "--no-input"
-                        "install" "--no-deps" "--prefix" #$output whl)))))))
+    (build-system pyproject-build-system)
     (native-inputs
      (list python-click
            python-poetry-core