summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-15 21:07:43 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-19 20:12:10 -0400
commit5c66f98c42bcdfe256d74cf7c298112d0562c0ec (patch)
treee35c4e54b8b08e4c8b0174f7c4cf1a71b2d9b917 /gnu/packages/python-xyz.scm
parent1344c3388a87d427209f63bdbfacabbd4c0a1033 (diff)
downloadguix-5c66f98c42bcdfe256d74cf7c298112d0562c0ec.tar.gz
gnu: python-xyz: Move some packages to (gnu packages python-build).
This is to prepare for the new 'python-hatchling' build package, which has
these dependencies.

* gnu/packages/python-xyz.scm (python-pathspec, python-pluggy): Move to...
* gnu/packages/python-build.scm: ... here.  Re-organize definitions a bit,
with comments.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm38
1 files changed, 0 insertions, 38 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 955c0f38c8..f39c09b950 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6121,25 +6121,6 @@ and integrated feature-set for programming Python effectively.")
 (define-public python-language-server
   (deprecated-package "python-language-server" python-lsp-server))
 
-(define-public python-pathspec
-  (package
-    (name "python-pathspec")
-    (version "0.9.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "pathspec" version))
-       (sha256
-        (base32
-         "1cdbdb3s6ldnjpwbi0bgl0xlmw4mbfxk08bbdxc3srx26na4jr75"))))
-    (build-system python-build-system)
-    (home-page "https://github.com/cpburnz/python-path-specification")
-    (synopsis "Utility library for gitignore style pattern matching of file paths")
-    (description
-     "This package provides a utility library for gitignore style pattern
-matching of file paths.")
-    (license license:mpl2.0)))
-
 (define-public python-black
   (package
     (name "python-black")
@@ -15574,25 +15555,6 @@ library as well as on the command line.")
    (home-page "https://stuvel.eu/rsa")
    (license license:asl2.0)))
 
-(define-public python-pluggy
-  (package
-   (name "python-pluggy")
-   (version "1.0.0")
-   (source
-    (origin
-     (method url-fetch)
-     (uri (pypi-uri "pluggy" version))
-     (sha256
-      (base32
-       "0n8iadlas2z1b4h0fc73b043c7iwfvx9rgvqm1azjmffmhxkf922"))))
-   (build-system python-build-system)
-   (native-inputs (list python-setuptools-scm))
-   (synopsis "Plugin and hook calling mechanism for Python")
-   (description "Pluggy is an extraction of the plugin manager as used by
-Pytest but stripped of Pytest specific details.")
-   (home-page "https://pypi.org/project/pluggy/")
-   (license license:expat)))
-
 (define-public python-plumbum
   (package
     (name "python-plumbum")