summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-03-24 15:58:17 -0400
committerLeo Famulari <leo@famulari.name>2020-03-24 17:10:21 -0400
commitf6c784806e130ec42784aeb2c91e62da39aa98bc (patch)
tree9fc3bebd1189a031aa94c8fc31daf1b33b2c7062 /gnu/packages/python-xyz.scm
parent1655e7be7858cbe4dc1ada88a53d4efe50a5d957 (diff)
downloadguix-f6c784806e130ec42784aeb2c91e62da39aa98bc.tar.gz
gnu: Add python-xattr.
* gnu/packages/python-xyz.scm (python-xattr): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e35a261ca4..c36134a2bf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18527,3 +18527,26 @@ content models.")
  with the eSign REST API.  Send, sign, and approve documents using this client.")
     (home-page "https://www.docusign.com/devcenter")
     (license license:expat)))
+
+(define-public python-xattr
+  (package
+    (name "python-xattr")
+    (version "0.9.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "xattr" version))
+       (sha256
+        (base32
+         "0i4xyiqbhjz2g16zbim17zjdbjkw79xsw8k59942vvq4is1cmfxh"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-cffi" ,python-cffi)))
+    (home-page "https://github.com/xattr/xattr")
+    (synopsis
+     "Python wrapper for extended filesystem attributes")
+    (description "This package provides a Python wrapper for using extended
+filesystem attributes.  Extended attributes extend the basic attributes of files
+and directories in the file system.  They are stored as name:data pairs
+associated with file system objects (files, directories, symlinks, etc).")
+    (license license:expat)))