summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-22 00:47:38 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-22 02:36:21 +0200
commitfa9d14ac50cf946e94caa244c25e0b2ec16b0e13 (patch)
tree03d41a35720e1f4bf48f9f0748a909cb7b264205 /gnu/packages/python-xyz.scm
parent441e6d936fd24acc9fe7d609735722a9f49a07cc (diff)
downloadguix-fa9d14ac50cf946e94caa244c25e0b2ec16b0e13.tar.gz
gnu: python-serpent: Update to 1.28.
* gnu/packages/python-xyz.scm (python-serpent): Update to 1.28.
[native-inputs]: Add python-attrs & python-pytz.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 330c784848..6eb4ba1886 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -615,15 +615,17 @@ version identifier.")
 (define-public python-serpent
   (package
     (name "python-serpent")
-    (version "1.27")
+    (version "1.28")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "serpent" version))
        (sha256
-        (base32
-         "04p9dsrm5pv8vhk3flvih55kgvlzpi38hlaykdiakddmgwqw93bg"))))
+        (base32 "1arnckykpkvv2qrp49l1k7q5mr5pisswl0rvdx98x8wsl1n361pk"))))
     (build-system python-build-system)
+    (native-inputs
+     `(("python-attrs" ,python-attrs)
+       ("python-pytz" ,python-pytz)))
     (home-page "https://github.com/irmen/Serpent")
     (synopsis "Serializer for literal Python expressions")
     (description